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Igor Pro ガイドツアー（1-2 – より複雑なグラフ１） 

データの読み込み 

 

ファイルからデータを読み込み、より複雑なグラフを作成します。さらに、Igor Pro を使っていくうえで、欠かす

ことのできないマクロについても触れます。 

ここでは、データは Igor Pro に付属しているサンプルを使います。 

 

1．ガイドツアー 1A で作成した Experiment ファイル

「Tour1A.pxp」を開きます。 

Experiment ファイルを開くと、ファイルを保存したときのワーク

スペースの状態に復元されます。 

Experiment ファイルは、File メニューの Open Experiment で

選択するか、Experiment ファイルをダブルクリックするか、また

は File → Recent Experiment → Tour1A.pxp を選択します。 

 

2．メニュー File → Open File → Notebook を選択します。 

 

3．C:\Program Files\WaveMetrics\Igor Pro 9 

Folder\Learning Aids\Sample data まで移動し、Tutorial data 

#1.txt を選択します。 

Igor Pro 9 フォルダーは、通常、C:\Program Files\WaveMetrics 

にインストールされます。 

ファイルの内容を示すノートブックウィンドウが表示されます。 

必要に応じて、データを編集し、保存することができます。 

現時点では、ファイルがタブ区切りであり、列の名前が含まれてい

ることがわかります。最初の列の名前は、これまでに入力したデー

タ名と競合し、他の名前には空白文字が含まれています。 
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4．内容を確認したので、このウィンドウを閉じます。 

閉じようとすると、確認画面が表示されるので、Kill をクリック

します。 

「kill」という用語は、「Experiment から完全に削除する」とい

う意味です。 

ファイルには影響しません。 

 

5．メニュー Data → Load Waves → Load Delimited Text 

を選択し、先ほどの Tutorial data#1.txt を選択します。 

Loading Delimited Text ダイアログが表示され、timeval という

名前がハイライトされ、エラーメッセージが表示されます。 

他の２つの列の名前は、空白文字をアンダースコア文字に置き換え

ることで修正されていることに注意してください。 
 

6．ウェーブ名 timeval を timeval2 に変更し、Make table 

にチェックを入れます。 

上のプレビュー部分で確認したら、左下の Load ボタンを押しま

す。 

データがロードされ、そのデータを表示するための新しいテーブル

が作成されます。 

 

7．テーブルで内容が確認できたら、テーブルを閉じます。 

 

8．確認画面が表示されます。既にデータは Igor Pro に取り込

まれているので、No Save で閉じます。 

テーブルウィンドウは単なる表示用であり、データがあれば表示は

不要です。 
 

 

ここで使った Load Delimited Text メニューは、区切り付きテキストを読み込むためのデフォルト設定を使うショ

ートカットです。 

後で独自のデータファイルを読み込むときには、メニュー Data → Load Waves → Load Waves を選択して、す

べてのオプションを表示してください。 
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既存のグラフにグラフを追加 

 

ガイドツアー 1A で作成したグラフに、今回読み込んだデータをグラフにして追加します。 

 

1．Graph0 のウィンドウを前面に持ってきます。 

Graph メニューは、対象のウィンドウがグラフの場合のみ使うこ

とができます。 

 

2．メニュー Graph → Append Traces to Graph を選択しま

す。 

Append Traces ダイアログが表示されます。これは、グラフを作

るときに使った New Graph ダイアログと非常に似ています。 
 

3．Y Wave のリストで voltage_1、voltage_2 を選択し、X 

Wave のリストで timeval2 を選択し、左下の Do It ボタンを

クリックします。 

グラフに２つの追加のトレースが追加されます。 

それらが凡例にも追加されていることに注目してください。 

 

4．追加されたトレースの値の区別がつかないため、折れ線のスタ

イルを変更します。 

 

5．ピーク値の高いほうのトレース（折れ線グラフ）の線をダブル

クリックすると、Modify Trace Appearance ダイアログが表示

されるので、Style のプルダウンメニューで 2 の点線を選択しま

す。 

左下の Do It ボタンで反映させます。 
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6．もう一方のトレースをダブルクックして、こちらは 3 の点線

を選択します。 

左下の Do It ボタンで反映させます。 

グラフは右のようになっているはずです。 

 

 

トレースのオフセット 

 

トレースを手動でオフセット（上下左右に移動）してみます。 

 

1．voltage_2 のトレースをマウスで１秒程度長押しします。 

点線が実線に変わります。 

グラフの左下に XY 座標が表示され、マウスの動きに合わせてト

レースが移動します。 

 

2．マウスボタンを押したままでグラフを 1cm ほど上のほうに

移動して、マウスボタンを離します。 

離した位置にトレースが移動します。 

Shift キーは、移動を垂直または水平方向に制限します。 

トレースにオフセットが追加されました。 

必要に応じて、トレースにオフセットを追加し、その量が示された

タグを追加することができます。 

このトレースのオフセットは、その下にあるウェーブデータには影

響しません。 

 

 

オフセットの解除 

 

オフセットしたトレースをもとの位置に戻します。 

 

1．メニュー Edit → Undo Trace Drag を選択します。 

（メニューには直前の操作が表示されます。今回は Trace Drag 

となります） 

トレースが元に戻ります。 
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Igor ウィンドウ上では、多くのインタラクティブな操作を元に戻

すことができます。 

2．Redo Trace Drag を選択すると、再度、オフセットが適用

されます。 

次の手順では、元に戻せなくなったオフセットを削除する方法を示

します。 

 

3．オフセットした voltage_2 のトレースをダブルクリックし

ます。 

voltage_2 が選択された状態で、Modify Trace Appearance ダ

イアログが表示されます。 

（voltage_2 が選択されていない場合は、それを選択します） 

Offset チェックボックスにチェックが入っているはずです。 

この画面でオフセットの位置を変更することもできることを覚えて

おいてください。 

 

 

 

 

 

 

 

 

 

4．Offset チェックボックスのチェックを外し、Do It ボタンを

クリックします。 

これにより、選択したトレースのオフセットがオフになり、ダイア

ログ内のオフセットコントロールは非表示になります。voltage_2 

のトレースが元の位置に戻ります。 
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グラフ内にオブジェクトを描く 

 

グラフの画面を最前面に表示しているところから始めます。 

 

1．Graph0 ウィンドウをアクティブにし、メニュー Graph → 

Show Tools を選択します。 

Ctrl+T キーでも実行できます。 

ツールパレットがグラフに追加されます。 

 

2．ドローツール  ボタンが選択されていて、グラフが「通常

モード」ではなく、「描画モード」であることを示します。 

 

3．一番上の  アイコンをクリックして、通常モードに入りま

す。 

通常モードは、トレース、軸、注釈などのグラフオブジェクトとの

やり取りをするためのモードです。 

描画モードは、線、四角形、多角形などを描画するためのモードで

す。 
 

4．二番目のアイコンをクリックして、描画モードに戻ります。 

 

5．ドローレイヤーツール  ボタンをクリックし、UserBack 

を選択します。 

使うことができる描画レイヤーとグラフレイヤーとの関係を示すポ

ップアップメニューが表示されます。 

メニューの項目は、後ろから前の順に表示されます。 

UserBack では、軸、トレース、その他のグラフ要素の背後に描画

します。 
 

6．四角ツール  をクリックして、グラフの左上（y=0.14, 

x=0）からドラッグして、右下の方（y=-0,2, x=1.6）までの長

方形を描きます。 
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7．直線ツール  をクリックして、グラフのピーク付近から右

に向かって線を引きます。 

 

8．描画環境ツール  をクリックして、Line Arrow → At 

Start を選択します。 

 

9．テキストツール  をクリックします。 

Create Text ダイアログが表示されます。 

今描いた矢印の右に配置し、Anchor を Left Center とし、

Text に「Precharge」と入力します。 

Do It をクリックします。 

 

10．配置を細かく修正するために、グラフの画面を最大化しま

す。 

元に戻すにも、ここを使います。 

グラフを拡大すると、長方形と線がどのように拡大するかを確認し

てください。 

それらの座標は、プロットエリア（軸で囲まれた長方形）を基準と

して決定されます。 

 

11．矢印ツール  をクリックし、描いた長方形をダブルクリ

ックします。 

Line Properties の Thickness を 0 に変更します。 

Fill の Fill Mode を Solid にします。 

Fore Color で薄いグレーを選択します。 
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12．Do It をクリックします。 

長方形が塗りつぶされます。トレースと軸の背後に描画されている

ことに注目してください。 

 

13．もう一度長方形をダブルクリックします。 

Modify Rectangle ダイアログが表示されます。 

Coordinate System の X を Axis Bottom に設定します。 

長方形の X 座標は、あたかもデータ値であるかのように、下軸を

基準として決定されます。 

 

14．長方形を正しい大きさ、位置に調整します。 

X0 に「0」、X1 に「1.6」、Y0 に「0」、Y1 に「1」を設定

し、Do It をクリックします。 

長方形の X 座標は、現在、下軸を基準として決定され、左側がゼ

ロ、右側が 1.6 となります。 

Y 軸は依然としてプロット領域に対する相対値として決定されま

す。Y 座標にゼロと 1 を入力したので、長方形はプロット領域の

高さ全体にわたることになります。 

 

15．  ボタンをクリックして、ドローモードを終了します。 

 

16．Alt キーを押しながら、グラフの中央付近をクリックして、

2cm ほど右にドラッグします。 

ドラッグに合わせて X 軸の範囲が変わります。長方形が下軸と一

直線になるように移動したことに注目してください。 
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17．前の操作は確認のためのものなので、元に戻しておきます。 

メニュー Edit → Undo Modify を選択します。 

 

 

ここまでの作業を保存するのを忘れないようにしましょう。 

次のステップに続ける場合は、ウィンドウを閉じません。 
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グラフを再表示するマクロ 

 

マクロ（プログラム）の第一歩として、作成したグラフをマクロで再表示してみます。 

もし、Experiment を閉じている場合は、Tour1A.pxp を開いたところから始めます。 

 

1．グラフのウィンドウを、ウィンドウのバーで閉じます。 

ウィンドウを再作成できるマクロとして保存するかどうかを聞いて

きます。 

グラフの名前は「Graph0」なので、「Graph0」というマクロ名

を提案しています。 

デフォルトの Graph0 をそのまま選択して、Save をクリックし

ます。 

Igor は、現在非表示のプロシージャウィンドウにウィンドウ再作

成マクロを生成します。ウィンドウ再作成マクロには、グラフ、テ

ーブル、ページレイアウト、コントロールパネル、または 3D プ

ロットを作成するために必要なコマンドが含まれています。 

このマクロを呼び出すことで、閉じたばかりのグラフを再作成する

ことができます。 

 

 

 

 

 

 

2．マクロを使ってグラフを再作成するには、メニュー 

Windows → Procedure Windows → Procedure Window 

を選択します。 

（Ctrl+m でも開きます） 

プロシージャウィンドウは常に表示されていますが、通常は邪魔に

ならないように隠れています。 

 

3．Graph0 を作成するためのマクロの内容が表示されます。 

このグラフを描くためにはこれを実行すればよいということです。 

ウィンドウには、Graph0 の再作成マクロが含まれています。 

マクロの開始部分を見るには、上方向にスクロールする必要がある

かもしれません。 

これは 

Window Graph0() : Graph 

のように宣言されます。 

このマクロは、Windows メニューの Graph Macros サブメニュ

ーから使うことができます。 
 

 

Igor で行った操作（GUI、コマンドライン）は、すべてコマンドウィンドウの履歴領域にコマンドとして保存され

ます。 
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一連の操作を再現するとき、マクロを作成するときなどに、この履歴領域から必要なコマンドを再利用することで、

今後の動作の効率化を図ることができます。 

今後使っていくうえで、この概念は非常に有用なので、ぜひ覚えてください。 

 

4．確認できたら、ウィンドウを閉じます。 

これにより、プロシージャウィンドウが非表示になります。 

他のほとんどのウィンドウでは、ウィンドウを終了するか非表示に

するかを確認するダイアログが表示されますが、ビルトインプロシ

ージャウィンドウとヘルプウィンドウは単に非表示になるだけで

す。 
 

5．グラフを再作成してみます。 

メニュー Windows → Graph Macros → Graph0 を選択しま

す。 

Igor は Graph0 マクロを実行し、同じ名前のグラフを再作成しま

す。 

 

6．グラフが再現されます。 

 

7．もう一度、メニュー Windows → Graph Macros → 

Graph0 を選択します。 

すると同じグラフが作成されますが、左上のグラフ名では 

Graph0_1 となっています。 

これは、すでに Graph0 が存在しているためです。 
 

8．重複しているものは不要なので、Graph0_1 を閉じます。 

この時、Alt キーを押しながら閉じると保存することなく、ウィン

ドウが閉じます。 
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Data Browser（データブラウザー）の使用 

 

Data Browser（データブラウザー）は、データをフォルダー階層で数値や文字列変数のウェーブや値を表示しま

す。 

 

1．メニュー Data → Data Browser を選択します。 

Data Browser が開きます。 

（Data Browser は起動時に既に表示されていることが多いで

す） 

 

2．Data Browser の左上のチェックボックスがすべてチェック

されていることを確認してください。 

（項目が多すぎてわかりにくい場合、Variables や Strings はオ

フにしてもよいかもしれません） 

 

3．階層表示のツリー表示で timeval ウェーブアイコンをクリッ

クして選択します。 

Data Browser の下部にあるプロットペインにウェーブが表示さ

れ、そのすぐ上にある情報ペインにウェーブのプロパティが表示さ

れます。 

表示されていない場合は、Data Browser ウィンドウの左側にあ

る情報アイコン（ ）をクリックしてください。 
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4．階層表示のツリー表示で timeval ウェーブアイコンを右クリ

ックします。 

その項目で実行できるメニューが表示されます。 

 

5．Esc キーで、コンテキストメニューを閉じます。 

Data Browser のクローズボックスをクリックしてウィンドウを

閉じます。 
 

 

ここまでの作業を別名で保存します。 

メニュー File → Save Experiment As を選択し、自分の Experiment を保存する Guided Tour フォルダーに移

動し、「Tour1B.pxp」という名前で保存します。 
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Igor Pro ドキュメントの使用 

 

このガイドツアーに加えて、Igor はツールチップ、一般的な使い方、参照できる情報を提供しています。 

これらは、オンラインヘルプファイルと Igor Pro PDF ファイルの両方で見ることができます。 

 

ツールチップ 

 

1．メニュー Misc → Miscellaneous Settings を選択しま

す。 

左のメニューで Help を選択し、Show Tooltips がチェックさ

れていることを確認してください。 

 

2．設定を変更したら、左下の Save Settings をクリックしま

す。 
 

3．メニュー Data → Load Waves → Load Waves を選択

します。 

Load Waves ダイアログが表示されます。 

このダイアログは、テキストデータファイルからデータを読み込む

方法である LoadWave コマンドに対するインターフェイスを提供

します。 
 

4．マウスの位置に合わせてツールチップが表示されます。 

この方法でほとんどのダイアログの項目とアイコンについてのヒン

トを得ることができます。 

右下の Cancel ボタンでダイアログを閉じます。 
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コマンドのヘルプ 

 

Igor は、メニューやダイアログを使うか、コマンドウィンドウでコマンドを実行してコントロールできます。 

操作によっては、コマンドを入力するほうがはるかに簡単に実行できる操作もありますので、コマンドやプログラミ

ングは習得していくとよいでしょう。 

コマンドに関する詳細な情報は、マニュアル II-2 The Command Window を参照してください。 

 

1．メニュー Help → Command Help を選択します。 

Help Browser が Command Help タブを選択した状態で表示さ

れます。 

このタブに表示される情報は、Igor 起動時に自動的に開かれる多

くのヘルプファイルの１つである Igor Reference ヘルプファイ

ルから取得されます。開かれているヘルプファイルは、メニュー 

Help → Help Windows で直接アクセスできますが、ここでは 

Help Browser を使います。 

 

 

 

 

 

 

 

 

2．左のリストをクリックすると、その説明が表示されます。 

Filter の入力部分に「L」を入力します。 

コマンドに「L」が含まれるものが表示されます。 

 

３．今は LoadWave コマンドが欲しいので、リストをスクロー

ルしたり、Filter に「Load」のように続く文字を入力して 

LoadWave までたどり着きます。 

Igor は、右側のヘルプエリアに LoadWave コマンドのヘルプを

表示します。 

参照ヘルプを見る別の方法は、コマンドまたは関数の名前を右クリ

ックして、「Help for」を選択することです。 

これは、コマンドウィンドウ、プロシージャ、ノートブック、ヘル

プウィンドウで動作します。 

 

 

 

 

 

 

 

 

 

4．次に左のリストの下の Filter に「Matrix」と入力します。 

リストには、名前に「matrix」を含む演算、関数、キーワードの

みが表示されます。 

 

5．左のリストの上の Show All をクリックすると、全リストの

表示に戻ります。 
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6．左下の Advanced Filtering を使って、さらにフィルター条件

を設定することができます。 

これらのコントロールは、左側のリストに表示される内容をフィル

タリンクする他の方法を提供します。 

 

 

オンラインマニュアル 

 

1．Help Browser 画面上部の Manual タブをクリックしま

す。 

右下の Open Online Manual ボタンをクリックします。 

 

2．コンピューターで PDF ファイルの表示に関連付けられている 

PDF ビューアーでマニュアルが表示されます。 

PDF ファイルの閲覧に Adobe Reader を使っている場合、PDF 

マニュアルの左側にブックマークパネルが表示されているはずで

す。 

表示されていない場合は、Reader でブックマークを有効にしてく

ださい。 
 

3．PDF ファイルにはブックマークが付いているので、目的の項

目に簡単にたどり着くことができます。 

PDF マニュアルが５つのボリュームとインデックスに分かれてい

ることを確認してください。 

 

 

ブックマークや目次を使って、マニュアルの内容を把握してください。ボリュームのしおりを開くと、各チャプター

名が表示されます。 

Igor の PDF マニュアルはかなりペース数が多いことに気づくかもしれません。最終的な集計では 2,000 ページを

越えています。 

しかし、最初から最後まで読む必要はないので安心してください。 

必要な章を必要なときに読んでください。 

マニュアルの情報はオンラインヘルプファイルにも記載されています。マニュアルは書籍形式なので、直線的な読み

方に適した構成となっていますが、オンラインヘルプは、通常、参照情報に直接アクセスするときに好まれます。 

直接開きたい場合は、Igor Pro フォルダーの Manual フォルダー内にあります（IgorMan.pdf）。 
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グラフィカルにデータを編集 

 

Tour1B.pxp で作成したグラフが表示されている状態から始めます。 

テーブルが表示されていなければ、メニュー Windows → Tables で開いておきます。 

見やすいようにテーブルとグラフを並べて表示しておきます。 

 

 

1．描画モードに切り替えるために、ドローツールアイコン  

をクリックします。 

 

2．ポリゴンアイコン  を長押しすると、ポップアップメニュ

ーが表示されます。 

メニューから Edit Wave を選択します。 
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3．yval トレースの円（マーカー）の１つをクリックします。 

データ点の位置を示すために、線と四角を使ってトレースが再描画

され、トレースとマーカーが変わって編集可能になります。 

 

4．左から２番目の四角（マーカー）をクリックして、1cm ほど

右上にドラッグします。 

テーブル内の yval と timeval の Point 1 も変更されます。 

 

5．Ctrl+Z でいったんキャンセルします。 

またはメニュー Edit → Undo を選択します。 
 

6．今度は左から１番目と２番目のマーカーの間の線を 1cm ほ

ど上にドラッグします。 

Yval と timeval のウェーブに新しいデータポイントが作成されま

す。 

 

7．Alt キーを押して、この新しいデータポイントをクリックする

と、そのポイントは削除されます。 

また、Ctrl＋Z を押して挿入を元に戻すこともできます。 
 

8．今度は２番目と３番目のマーカーの間の線を、Ctrl キーを押

しながら少し右にドラッグします。 

線分が移動し、yval と timeval の２つの点がテーブル内で変更さ

れます。 

 

9．２つのポイントが移動し、テーブルの値も変わります。 

Undo して、変更を元に戻します。 

 

10．  アイコンをクリックして、描画モードを終了します。 

 

11．メニュー File → Revert Experiment を選択し、確認画

面で Yes を選択します。 

これで各種の編集をする前の状態に戻ります。 
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カテゴリプロットの作成（オプションツアー） 

 

数値データと数値ではないテキストカテゴリとをプロットします。 

 

1．新しい Experiment を作成するため、メニュー File → 

New Experiment を選択します。 

 
 

2．メニュー Windows → New Table を選択します。 

 

3．次の画面は何もせず、そのまま Do It をクリックします。 

空のテーブルが作成されます。 

 

4．最初のセルに「Monday」と入力し、Enter キーを押しま

す。 

textWave0 という名前のウェーブが作られ、最初の Point の値

としてテキスト「Monday」が設定されました。 

最初の空白の列の最初の行に数値以外の値を入力すると、自動的に

新しいテキストウェーブが作られます。 
 

6．下の行に次を入力していきます。 

Tuesday 

Wednesday 

Thursday 

 

7．右側の列に次の値を入力します。 

10 

25 

3 

16 
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8．さらに右側の列に次の値を入力します。 

0 

12 

30 

17 

 

9．メニュー Windows → New → Category Plot を選択し

ます。 

New Graph ダイアログに似たダイアログが表示されます。 

このダイアログでは、右側のリストにテキストウェーブのみが表示

されます。 

 

10．Y Wave のリストで wave0 と wave1 を選択します。 

X Wave のリストで textWave0 を選択します。 

Do It をクリックします。 

カテゴリプロットが作成されます。 

 

11．棒グラフの一番左をダブルクリックします。 

Modify Trace Appearance ダイアログが表示されます。 

 

12．Modify Trace Appearance ダイアログの Color で色を変

更します。 

wave0 トレースに緑を選択し、Do It をクリックします。 

 

13．グラフは右のようになっているはずです。 

メニュー File → Save Experiment As を選択し 

CategoryPlots.pxp という名前で保存します。 
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カテゴリプロットのオプション（オプションツアー） 

 

このセクションでは、さまざまなカテゴリプロットのオプションについて説明します。 

カテゴリプロットに特に興味がない場合は、この時点で、または以降の手順のどの時点でも、終了したり、次のセク

ションにスキップすることができます。 

 

1．棒グラフの一番左をダブルクリックします。 

Trace Appearance ダイアログの Grouping で Stack on 

Next を選択します。 

緑を選択し、Do It をクリックします。 

 

2．各グループの左の棒グラフが右の棒グラフの上に積み重なりま

す。 

 

3．メニュー Graph → Reorder Traces を選択します。 

Reorder Traces ダイアログが表示されます。 

 

4．リストの項目をドラッグして、順番を入れ替えます。 

Do It をクリックします。 

棒グラフが積み重ねられなくなり、左側になった棒グラフが右側に

移動しました。積み重ねられない理由は、Stack on Next モード

に指定したトレースが最後になり、次のトレースがないためです。 

 

5．Trace Appearance ダイアログの Grouping で wave1 トレ

ースに対して Stack on Next を選択して、もう一度積み上げの表

示にします。 
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6．テーブルのさらに右側の列に次の値を入力します。 

これは wave2 となります。 

7 

10 

15 

9  

7．グラフ画面をアクティブにして、メニュー Graph → 

Append to Graph → Category Plot を選択します。 

Append Category Traces ダイアログが表示されます。 

 

8．Y Waves リストで wave2 を選択して、Do It をクリック

します。 

これにより、各緑色の棒グラフの下に赤い棒グラフが追加されま

す。 

 

9．棒グラフの下のほうの赤い部分をダブルクリックします。 

Modify Trace Appearance ウィンドウで Color を青にしま

す。 

Do It をクリックします。 

 

10．棒グラフの緑の部分をダブルクリックし、Modify Trace 

Appearance ウィンドウを表示します。 

 

11．wave0 の Grouping を None にし、Do It をクリック

します。 

これで、wave1（赤）が wave0（緑）に積み重ねられ、wave2

（青）は何も積み上げられていない状態です。 

新しい wave2（青）が、積み重ねられた棒グラフの右側に表示さ

れています。 

積み重ね、横の並びの組み合わせが自由に行うことができます。 
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12．グラフの横軸（X軸）をダブルクリックします。 

Modify Axis ダイアログが表示されます。 

 

Modify Axis ウィンドウで Auto/Man Ticks タブを選択し、

Tick In Center チェックボックスをチェックして、Do It をク

リックします。 

 

13．横軸の目盛の位置が変わったことに注目してください。 

もう一度横軸をダブルクリックします。 

 

14．Modify Axis ウィンドウで Axis タブを選択し、Bar Gap 

を 0 に設定し、Do It をクリックします。 

グループ内のバーが接触したことに注目してください。 

次に、Modify Axis ウィンドウで Category Gap を 50 に設定

し、Do It をクリックします。 

棒グラフの幅がカテゴリの幅の 50% に縮小されます。 

 

15．棒グラフの表示の間隔が変更されました。 

 

16．メニュー Graph → Modify Graph を選択します。 

 

17．Swap X ＆Y Axes にチェックを入れ、Do It をクリック

します。 

これが水平方向の棒グラフを作る方法です。 
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18．グラフの軸が入れ替わりました。 

メニュー File → Save Experiment を選択して保存します。 
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コマンドウィンドウ 

 

数学的な計算式を入力するためのコマンドラインを使う手順を確認します。 

新しい Experiment を作成して手順を進めます。 

 

1．メニュー File → New Experiment を選択します。 

画面の下部に右のようなウィンドウが表示されます。 

（もし表示されない場合は、メニュー Windows → Command 

Window を選択します） 

コマンドラインは赤いセパレーターの下のスペースで、セパレータ

ーの上は履歴領域と呼びます。 
 

2．コマンドライン・ウィンドウの下の領域（コマンドライン）を

クリックして、次を入力し、Enter キーを押します。 

Print 2+2 

 

3．ウィンドウの上の領域（履歴領域）に入力したコマンドと計算

結果が表示されます。 

 

4．上矢印キーを押します。 

履歴領域のコマンドが選択されます。 

 

5．Enter キーを押します。 

選択したコマンドがコマンドラインにコピーされます。 

 

6．コマンドラインを次のように書き換えます。 

Print “The result is “, 2+2 

Print コマンドは、数値または文字列の式のリストを受け取り、そ

れらを評価し、結果を履歴に表示します。 

 

8．Enter キーを押すと右のように履歴領域に表示されます。 
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ヘルプで音を再生するコマンドを探して再生 

 

1．メニュー Help → Igor Help Browser を選択します。 

Igor Help Browser が表示されます。 

コマンドウィンドウの右端付近にあるクエスチョンマークのアイコ

ンをクリックするか、F1 キーを押すことでも Help Browser を

表示できます。 

 

 

 

 

 

 

２．Command Help タブを選択します。 

Advanced Filtering で、Functions と Programming のチ

ェックボックスをオフにし、Operations チェックボックスをオ

ンにします。 

高度なオプションが必要な場合は、Advanced Filtering をクリッ

クします。 

左側のリストの上に Show All リンクがある場合は、それをクリ

ックします。 

 

 

 

 

 

 

 

 

 

3．Operations のポップアップメニューで About Waves を

選択します。 

 

4．リストから PlaySound を選択します。 

フィルターの部分に「P」と入力するとより早く特定できます。 

PlaySound コマンドのリファレンスヘルプは、右側のヘルプエリ

アに表示されます。 

 

5．右のヘルプのテキストスクロールし、Example まで移動しま

す。 

サンプルコマンドの Make から PlaySound sineSound まで

をコピーします。 

メニュー Edit → Copy メニューでも実行できます。 

Igor Help Browser を閉じます。 

 

6．コマンドラインの領域を縦に少し大きくして、貼り付けます。 

メニュー Edit → Paste でも実行できます。 

４行すべてがコマンドラインエリアに貼り付けられます。 

コマンドウィンドウを縦長にし、赤いセパレーターを上にドラッグ

すると、コマンドラインのコマンドが見えるようにします。 
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7．Enter キーを押します。 

コマンドが実行され、短い音が流れます。 

履歴の最後の行を１回クリックしてハイライトします。 

 

8．Enter キーを押します。 

コマンドラインに行がコピーされ、もう一度 Enter キーを押す

と、再度音が流れます。 

 

9．一連の確認が終わったので、データを消去します。 

メニュー Data → Kill Waves を選択します。 

 

10．sineSound を選択して、Do It をクリックします。 

sineSound ウェーブがメモリから消去されます。 

 

11．ウェーブを消去した状態で履歴領域から PlaySound 

sineSound をコマンドラインにコピーして実行してみます。 

 

12．メモリ上に sineSound ウェーブが存在していないため、エ

ラーとなります。 

OK でエラーダイアログを閉じます。 
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13．メニュー Edit → Clear Cmd Buffer を選択するか、

Ctrl+K キーを押します。 

コマンドがエラーとなった場合、コマンドラインにエラーが残るた

め、編集して再実行することができます。 

この場合、コマンドラインをクリアするだけで十分です。 
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データの生成 

 

ウェーブを作成して、数式を使ってデータを埋める手順です。 

 

1．新しい Experiment を作成するため、メニュー File → 

New Experiment を選択します。 

これにより、以前の Experiment で残ったウィンドウやデータが

すべて消去されます。 

 

 

 

 

 

 

2．メニュー Data → Make Waves を選択します。 

Make Waves ダイアログが表示されます。 

 

3．最初のボックスに「spiralY」と入力し、Tab キーで隣に移動

し、次のボックスに「spiralX」と入力します。 

Rows の値を「1000」に変更します。 

Do It ボタンをクリックします。 

1000 ポイントのウェーブが２つ作成されました。 

これらは現在、Experiment の一部となっていますが、テーブルや

グラフに表示されていないため、見ることができません。 
 

４．メニュー Data → Change Wave Scaling を選択しま

す。 

Change Wave Scaling ダイアログが表示されます。 

このダイアログを使って、ウェーブの X スケーリングを設定しま

す。 

 

5．もし More Options ボタンがあればクリックしてください。 

そうでなければ Fewer Options ボタンが表示されています。 
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6．リストで spiralY と spiralX の両方選択して、SetScale 

Mode で Start and Right を選択します。 

 

7．その上の部分では Start には 0、Right には 50 を設定

し、Do It をクリックします。 

これは、spiralX と spiralY のウェーブの X スケーリングを指定

する SetScale コマンドを実行します。 

X スケーリングは、ポイント番号を X 値にマッピングするウェー

ブのプロパティです。 

この場合、ポイント番号 ０ から 999 を X 値 0 から 50 にマ

ッピングします。 

 

 

 

 

 

8．コマンドラインに 

spiralY = x*sin(x)  

を入力して、Enter キーを押します。 

これは、ウェーブフォームの割り当て文です。 

宛先のウェーブ（spiralY）の各ポイントに値を割り当てます。与

えられたポイントに格納される値は、そのポイントにおける右辺の

値です。 

ウェーブフォーム代入文における x の意味は、宛先ウェーブの X 

スケーリングによって決まります。この場合、Igor が 0 から 

999 までのポイントの右辺の式を評価するため、x は 0 から 50 

までの値をとります。 

 

 

 

 

 

 

 

9．コマンドラインに 

spiralX = x*cos(x) 

を入力して、Enter キーを押します。 

 

10．これで spiralX と spiralY がデータ値のセットを持ちまし

た。 
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グラフのズームとパニング 

 

前のセクションの続きから始めます。 

 

1．メニュー Windows → New Graph を選択します。 

 

2．必要であれば、From Target チェックボックスを外します。 

Y Wave のリストで、spiralY、X Wave のリストで 

_calculated_ を選択します。 

Do It をクリックします。 

 

3．spiralY のデータ値と X 値のグラフが表示されます。 

X 軸は 0 から 50 までであることに注意してください。 

これは、先に実行した SetScale コマンドが、Igor にポイント番

号から X 値を計算する方法を指示するための spiralY の X スケ

ーリングのプロパティを設定したためです。 

X Wave リストで _calculated_ を選択すると、spiralY のデータ

値がこれらの計算された X 値に対してグラフ化されます。 
 

4．グラフの中でクリックし、ドラッグして右のような長方形を作

成します。 

ハンドル（黒い四角）で選択範囲のサイズを変更できます。 

また、破線の端をドラッグして範囲を移動できます。 

 

5．この四角の中にマウスカーソルを移動すると、ポインタが変わ

り、ポップアップメニューが使用可能になります。 

メニューから Expand を選択します。 
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6．選択範囲がグラフ全体を占めるように、軸が再スケールされま

す。 

 

7．メニュー Edit → Undo Scale Change または Ctrl+Z キ

ーで拡大をキャンセルします。 

 

8．メニュー Edit → Redo Scale Change または 

Ctrl+Shift+Z キーで拡大を再適用します。 
 

9．Alt キーを押しながら、グラフの中央付近でマウスボタンを押

します。 

マウスカーソルが手の形になり、ドラッグするとグラフが移動しま

す。2 cm ほど左にドラッグしてみます。 

データが変わるわけではないため、合わせて軸も移動します。 

 

10．メニュー Graph → Autoscale Axes または Ctrl+A を

押すと元の軸の範囲に戻ります。 

グラフウィンドウを閉じます。 

データは次のセクションでも使います。 
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複数の軸を持つグラフ 

 

前のセクションのデータを使って。複数の軸を持つグラフを作成します。 

 

1．メニュー Windows → New Graph を選択します。 

 

 

2．More Options ボタンをクリックします。 

より複雑なダイアログを使って、１ステップで複数軸のグラフを作

ります。 

 

3．Y Wave で spiralY を選択し、X Wave で spiralX を選

択して、Add ボタンを押します。 

選択した項目は、ダイアログ下のリストに追加されます。 

 

4．今度は、Y Wave で spiralY を選択し、X Wave で 

_calculated_ を選択し、X Wave のリストの下のポップアップ

メニューで New を選択します。 

 

5．Name に B2 と入力し、OK をクリックします。 

ダイアログ下部のコマンドボックスに注目してください。 

このコマンドボックスには、２つのコマンドが含まれています。 

１つは、下のリストに追加した最初の選択項目に対する Display 

コマンド、もう１つは Y Wave と X Wave のリストで現在選択

されている項目に対する AppendToGraph コマンドです。 

元の画面で Do It をクリックします。 
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6．次のようなグラフが作成されます。 

内部の軸は、プロットの領域に対して移動できるため、自由軸と呼

ばれます。 

この軸をプロット領域の外側に移動しようと思いますが、その前に

プロット領域の余白を調整してスペースを確保する必要がありま

す。 
 

7．下の X 軸に Alt キーを押しながらポインタを重ねるとアイ

コンが変わるので、選択して上にずらし、下にスペースを作りま

す。 

 

8．上の X 軸を選択して、下にドラッグして、空いたスペースに

移動します。 

 

9．メニュー File → Save Experiment As で、

「Tour1C.pxp」と名前を付けて保存します。 

デフォルトの場所は、 

C:\Users\<ユーザー名>\Documents\WaveMetrics\Igor Pro 9 

User Files 

だったことを思い出してください。 
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