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About Ion Ratio Imaging

Ion ratio imaging is a relatively new technique for measuring either absolute or relative
changes in ion concentration within living cells.  This is accomplished by measuring the
fluorescence emission of special dyes which have been designed to change their spectral
properties and/or emission intensities upon binding to the ion of interest.  Cells are loaded
with dye by either bathing them in solution containing a membrane-permeant form of the
dye or by injecting the dye using a glass micropipette. The intracellular fluorescence is
subsequently monitored with a microscope and specialized imaging equipment.  For
information about the dyes used for ion ratio imaging see the Molecular Probes web site,
www.probes.com, or Molecular Probes' Handbook of Fluorescence Probes and Research
Chemicals, available upon request (1-541-465-8300).  For information about the theory
and practice of ion ratio imaging, the following references are suggested:

• Methods in Cell Biology,  Vol. 29: Fluorescence Microscopy of Living Cells in Culture (Parts A
and B), Yu-Li Wang and D. Lansing Taylor (eds.), 1989 Academic Press, New York.

• Cellular Calcium. IRL Press Practical Approach Series, J.G. McCormack and P.H. Cobbold,
(eds.), 1991 IRL Press, New York.

• Methods in Cell Biology, Vol. 40: A Practical Guide to the Study of Calcium in Living Cells, R.
Nuccitelli (ed.), 1994 Academic Press, New York.

• Grynkiewicz, G., Poenie, M., and Tsien, R.Y. (1985)  A new generation of Ca2+ indicators with
greatly improved fluorescence properties.  Journal of Biological Chemistry  260: 3440-50.

RatioImg Procedures Overview

The RatioImg procedures are a set of Igor procedure files which provide convenient data
loading, browsing, annotation, and measurement of ratiometric imaging experiments.
They were written by Howard Rodstein at WaveMetrics and Mark N. Rand at the
Department of Neurology, University of Washington, Seattle.  IGOR Pro 3.1 is used to
load and run the RatioImg procedure files.  Igor is an integrated program for visualizing,
analyzing, transforming and presenting scientific data, and is available from
WaveMetrics, Inc. of Lake Oswego, OR.

The RatioImg procedures do not perform data acquisition or make ROI measurements;
you will have to use other software to do this.  Acquisition software is often sold with
imaging hardware, which typically consists of a CCD camera, frame-grabber or digital
interface board, device for controlling illumination wavelength, and illumination source.
Examples of vendors who provide ratiometric imaging systems are Inovision
Corporation, Universal Imaging, Life Science Resources, and Axon Instruments.
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If your acquisition/ROI measurement software can save data from each wavelength in the
CSV format described in RatioImg Assumptions below, RatioImg should be able to
read the file, generate ratiometric plots, and allow you to make measurements and
analyses.  If your software acquires and saves data as precalculated ratio values or in
other single-column per ROI format (such as data from single-wavelength dyes) you can
still import it and perform measurements and analyses; please see the Appendix for
details. The Appendix also describes how to plot F/F0 or ∆F/F (i.e, fluorescence relative
to baseline) for single-wavelength dyes.

The procedures were designed to work with data collected by a typical ion ratio imaging
system. With this system cells are imaged on an inverted microscope using an intensified
CCD camera. The image is displayed on a computer monitor and the user selects the cells
to be measured by drawing their outlines freehand-style with the computer mouse. The
selected areas are known as "regions of interest," or ROIs.  Before starting an experiment
the investigator also specifies the frequency of data acquisition, amount of signal
averaging, camera settings, etc.  During the experiment the computer controls the
illumination of the cells using two different wavelengths (referred to as A and B) and
measures the fluorescence intensity within each ROI for each wavelength.  These values
are stored in a spreadsheet-style data file.  Paired columns in the data file contain the
wavelength A and B data for each ROI, and rows represent the time sequence. For
shorthand reference, the terms "ROI" and "cell" are often used interchangeably in this
help file to refer to data from a measured region.

The calibration scaling procedure in RatioImg was designed for experiments which
conclude with the application of two or more in situ calibration solutions.  The cells are
permeablized with ionophores and perfused with a sequence of solutions containing
different concentrations of the measured ion; the ion concentrations are selected to cover
the range of ion changes which occurred during the experiment.  The RatioImg correction
procedure scales the ratio data from each cell and plots it in absolute ion concentration
based on the cell's own calibration signals. This method does not rely on determining or
guessing the dye's Kd within the cell, measuring Rmin and Rmax in situ or in a cuvette,
etc.  Specifically, the current correction procedures do not allow the user to enter values
into the Grynkiewicz, Poenie, and Tsien (1985) formula.  This utility might eventually be
added to the RatioImg procedures, hopefully with feedback from someone having a
vested interest in using it.

RatioImg was tested using IGOR Pro 3.13 on a Mac PPC 603e running at 200 MHz. This
CPU provides adequate processing power to browse through cells having up to 600
points per wave, although it can be somewhat sluggish when performing measurements
in batch mode or when batch-transferring graphs to the RatioImg Notebook.  The
procedures were less-extensively tested on a Pentium 166 under Windows 95, and appear
to perform well on this platform.
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RatioImg Files

The RatioImg package is distributed in two archives, which differ only in their
compression formats: RatioImg.sit for Mac and RatioImg.zip for Windows.  Each archive
contains the following files:

 - Readme.txt     (brief description and instructions)
 - RatioImg.pdf  (the RatioImg Help file in Adobe Acrobat format)

RatioImg Procedures folder:
- RatioImg Calibration Periods
- RatioImg Data Loading
- RatioImg Graphs
- RatioImg Help
- RatioImg Measurements
- RatioImg Diagrams
- RatioImg Utilities

Sample Files folder:
- 990401A.CSV (data file)
- 990401B.CSV (data file)
- 990401A.pxp (Igor experiment file)

Outline of the Procedures

This outline describes the operation of the procedures.

A. Load the data and do some preliminary processing (LoadRatioImgFile).
1. Load data from file into a new data folder, creating two background waves (bkgA,

bkgB) and n-1 data waves (Ai, Bi, for i = 2..n).
2. Do the background subtraction (Ai = Ai - bkgA; Bi = Bi - bkgB) if background

subtraction is turned on (gDoBkgSub - set via RatioImg ➔ Data Loading).
3. Create the ratio waves (Ri = Ai / Bi).

B. Display the data (CreateRatioImgGraphs).
1. Display a graph of A2, B2, & R2.
2. Allow the user to page forward or back through the data in the run, or to move to

another run in the Data Browser.

C. Set the calibration solution information to be used by the ratio correction routine.
1. Allow the user to specify the calibration information using the Set Calibration

Period control panel.
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D. Do the ratio correction (CorrectRatioImgRatios).
1. Compute the average ratio values for each calibration solution period.
2. Find the slope and y-intercept between each calibration period's average ratio value.
3. Create the corrected ratio waves.
4. Generate an average wave of all the corrected waves, which can be displayed in a

separate graph window and measured.

E. Document the experiment (AddGraphToNotebook).
1. Allow the user to automatically format and copy the currently-displayed graph to

the RatioImg notebook.
2. Allow the user to specify the number of graphs to automatically format and copy to

the RatioImg notebook, starting with the currently-displayed graph.

F. Measure the waves (AddMeasurementFromCursors).
1. Compute the following measures from a wave segment defined by the A and B

cursors and store them in a table: data filename.wave ID, start time of measurement,
stop time of measurement, average value, standard deviation, slope, Pearson's r, y
start value, y stop value.

2. Compute a linear curve fit between the A and B cursors and plot the fit on the
graph.

3. Allow the user to specify the number of graphs to measure using the current A-to-B
cursor positions, and automatically measure the graphs starting with the currently-
displayed graph.

4. Allow the user to delete the last set of measurements from the table, delete a
specified number of measurements from the table beginning with the last made,
delete all measurements from the table, or delete all linear curve-fit plots from the
graph.

G. Work with single-column per ROI data (see Appendix).
1. Load single-column data and do some preliminary processing

(LoadSingleROIDataFile).
2. Do background subtraction if desired (see Section A2 above).
3. Calculate and plot F/F0 or ∆F/F values (CorrectFFos or CorrectDeltaFFs).
4. Display, document, and measure the data as described above for ratiometric

datafiles.

RatioImg Setup

The procedure files are stored in a folder named RatioImg Procedures. This folder should
be located outside the IGOR Pro folder so that if you upgrade IGOR Pro the procedure
files will not be affected.

Make an alias (Macintosh) or shortcut (Windows) for the RatioImg Procedures folder and
drag the alias or shortcut into the User Procedures folder, which is inside the IGOR Pro
Folder.
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If you are running on Windows, the files in the RatioImg Procedures folder must have an
".ipf" (Igor procedure file) extension, except for the RatioImg Help file, which must have
an ".ihf" extension. Check the folder and add the extensions if necessary. On Macintosh
the files should have no extensions. For the Macintosh version, please allocate at least
16 MB of program memory to Igor.

Launch Igor.  To use the RatioImg procedures in a new Igor experiment, open the built-in
procedure window (choose Procedure Window from the Windows menu), and type the
following line, flush against the left margin:

#include "RatioImg Main"

Now close the procedure window. Igor will load the RatioImg Main procedure file and a
number of other procedure files which the RatioImg Main file includes. To see what
procedure files were loaded, click on the Windows ➔ Other Windows menu.

Note that a new menu, RatioImg, has appeared in the menu bar. From the RatioImg
menu, choose Initialize. This creates a number of global variables and waves which are
used by the RatioImg procedures. NOTE: You must run the Initialize procedure once
each time you load the RatioImg procedures into a new Igor experiment. No harm is done
if you run it again.

RatioImg Guided Tour

This guided tour demonstrates how to use the RatioImg procedures. It also contains many
tips for performing data analysis and annotation of your experiments. It will be easier to
follow the tour if you display this help file on a second screen or, if you have only one
screen, by printing this documentation file.

It is also assumed that you have the two sample RatioImg data files included in the
RatioImg distribution archive.

1. Setting Up an Experiment File

* Create a new Igor experiment by choosing New Experiment from the File menu.

* Choose Data ➔ Data Browser. Position the Data Browser window in a convenient part
of the screen. The Data Browser is used extensively by the RatioImg procedures.

* Choose Windows ➔ Procedure Window.

* Enter the following in the procedure window, flush against the left margin:

#include "RatioImg Main"
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* Close the procedure window. If you get an error see RatioImg Setup, above.

* Examine the Windows ➔ Other Windows menu to see what procedure files were
loaded. You can open the RatioImg Main procedure file and read the #include
statements in it. After doing this, hide (do not kill) the RatioImg Main procedure file.

* Note the RatioImg menu in the menu bar. Choose RatioImg ➔ Initialize. This creates a
number of global variables (described below) which are used by the RatioImg
procedures. Notice in the Data Browser that a data folder named Packages has been
created.  Open the Packages icon in the Data Browser by clicking on the triangle to its
left.  The Packages folder contains the RatioImg data folder. Open the RatioImg data
folder to reveal the globals created by the Initialize procedure. Close both icons. You
must run the Initialize procedure once when you load the RatioImg procedures in a new
Igor experiment.

* Choose RatioImg ➔ Data Loading. Leave the default values as they are for now. Later
you may want to change them. Click the Continue button to dismiss the dialog.

* Choose RatioImg ➔ Load Data. In the resulting Open File dialog, find one of the
sample RatioImg Data files and open it. (The procedures assume that data files have
names like 981209A.CSV; without this type of name format you won't be able to load
the file).

* In the Data Browser, notice that a new data folder has been created with a name like
R981209A. "R" stands for "Run". Open the new run data folder icon by clicking on the
triangle to the left of its name.  At the top of the list you will see two waves named
bkgA and bkgB - these are the background data from the first two columns in the CSV
data file.  After this you will see A2/B2, A3/B3, . . . An/Bn. These are waves
corresponding to the original A and B data for each ROI.  After this you will see R2,
R3, . . . Rn. These are the calculated ratio waves. Close the run data folder icon.

* Click on the new run data folder icon to select it. It must be the only thing selected in
the Data Browser. Now choose RatioImg ➔ Create Graphs. This creates a graph of the
first cell in the new run (A2, B2, & R2).  It also creates the Experiment/ROI Browser
panel the Set Calibration Period panel, and the RatioImg Notebook file.

* Load the other sample data file by invoking RatioImg ➔ Load Data...  Notice in the
Data Browser that you now have two run data folders.

* The Experiment/ROI Browser control panel, allows you to browse through different
cells in an experiment or to move through different experiments which have been
loaded into the Data Browser list. Try using the Next Cell and Prev Cell buttons and the
Next Run and Prev Run buttons.

* The graph has two y-axes.  By default the A and B data are autoscaled from zero and
plotted in magenta and cyan, respectively, whereas the ratio data are displayed from 0.4
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to 4 and plotted in black. The ratio data axis values are hard-wired; they can be changed
as noted in the RatioImg Style function in the RatioImg Graphs procedure file. You can
also double-click on the graph's axis values to edit the settings in a dialog box.  To
autoscale each cell in the graph use cmd-A on Macintosh or Ctrl-A on Windows.

* Axis scaling can also be set to cover the range encompassed by all cells in a single
experiment or across all experiments. Choose RatioImg ➔ Axis Ranges. Examine the
popup menus in the resulting dialog. This dialog causes the axes in the active graph to
be set to fixed, automatically-derived ranges in order to make it easier to compare one
cell to another.

2. Calibrating the Ratio Values

* The Set Calibration Periods control panel should appear when you run Create Graphs,
as described above; it can also be invoked from the RatioImg menu. This control panel
allows you to specify the time periods during which, at the experiment's conclusion,
calibration solutions were applied, as well as the ion concentrations of these solutions.

* A gray line should appear in the graph. On Windows, you may need to click on the
graph and then on the control panel to make the gray line appear.

* On Macintosh, press the Control, Option, and Command keys simultaneously and move
the cursor over each of the controls in the panel. This displays balloon help for each
control.  On Windows, the help information appears in the status bar at the bottom of
the Igor Pro window.

* Click on the graph window. The Info panel should be visible at the bottom of the graph;
if not, choose Show Info from the Graph menu (or cmd-I / Ctrl-I from the keyboard).
Drag cursor A (the round one) onto the ratio wave near the center of Period 0 (the part
of the trace with the lowest ratio values, about 3/4 of the way through either of the
sample experiments). Click on the control panel again and then click the Set From
Cursor button. This sets the center time for Period 0.  Alternatively, you can enter a
value in the Center Time box; clicking outside the entry box updates the position of the
gray line. Clicking the up/down controls on the entry box moves the gray line in 10-
second increments, allowing you to fine-tune the center position. The Duration value
sets the time interval over which the average ratio is measured during the calibration
solution application. The Solution value for Period 0 should be set to the lowest used in
the calibration series, typically a concentration of 0 for the measured ion.

* Enter 1 in the Period box in the control panel and then set the various parameters for
Period 1 (the next plateau step in the trace). Do the same for period 2 (the next plateau
step). Continue until all the calibration periods are specified. Up to 10 calibration
periods can be entered.  The Readme.txt file contains details regarding the actual
calibration solutions used for the sample data.  Also, please see the RatioImg
Assumptions section below for details on entering the calibration data.
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* When you're finished setting the Period information, drag the cursor off the graph.

* In the Data Browser open the run data folder icon for the run that is displayed in the
graph. Notice a wave named periodInfo. This contains the settings that you just set via
the control panel. Double-click the periodInfo icon in the Data Browser to see the wave
in a table. In addition to the settings that you entered the table contains default values
for periods which are not used in the calculations; this is normal and does not affect the
calibration of the data.  After inspecting the values, close the table without saving it.

* There are two ways to invoke the procedure which corrects the ratios and plots the data
in absolute ion concentration. The first method operates on selected run folders in the
Data Browser as follows.  In the Data Browser select the data folder of the run that you
want to correct. It must be the only thing selected in the Data Browser. Now choose
RatioImg ➔ Correct Ratios. This runs the ratio correction algorithm for all cells in the
selected run, using the calibration period information that you entered in the control
panel. IMPORTANT: You must remember to select the appropriate run data folder in
the Data Browser before choosing Correct Ratios from the menu.

* The other method to invoke the correction procedure is to click the "Correct Ratios"
button on the Set Calibration Periods panel. This corrects the ratios for the run currently
displayed in the Graph window.

* The procedure will check before performing the correction to see if the data in the
folder or graph have already been corrected, in which case it will stop and display a
message to this effect.  Otherwise, if the data have not already been corrected a dialog
box will appear asking whether you want to proceed. You should click "Yes" only if
you are certain that the calibration period settings are correct. Clicking "No" will abort
the correction procedure and allow you to check the settings.

* Note: Upon applying the correction all of the ratio waves in the run are overwritten by
the corrected values.  It is not possible to undo this.  You can easily inspect or measure
the ratio values before making the correction. If you want to browse the ratio values
after correcting them you will have to reload the original data. If you prefer to retain the
ratio waves you can load the data, select the data folder in the Data Browser, Duplicate
it (from the Edit menu, or use cmd-D or Ctrl-D from the keyboard), give the new folder
a distinctive name, then apply the correction to the new folder.

* If you make a mistake in setting the calibration periods or their values in the Set
Calibration Periods control panel you will have to delete the data folder in the Data
Browser, reload the original data file, and re-specify the calibration information.  (If
you duplicated the ratio waves folder before making the erroneous correction you can
simply duplicate it again instead of reloading the data.)

* Doing the correction changes the magnitude of the ratio waves. The corrected values
are displayed at a fixed scale of -5 to 105.  To rescale the graph axes, either execute the
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autoscale command (cmd-A or Ctrl-A), use the RatioImg ➔ Axis Ranges... dialog, or
double-click on any axis label value to open the Set Axis Range dialog and edit the
settings. (The hard-wired default values are located in the CorrectRatioImgRatios
procedure in the RatioImg Data Loading file if you want to permanently change them.)

* Close the Set Calibration Periods panel when you have finished correcting the data.

3. Reviewing and Annotating Graphed Data

* Click "Next Cell" or "Prev Cell" in the Expt/ROI Browser control panel to review the
corrected plots. The calibration signals should match the scaling for the left y-axis; e.g.,
the signals for the 0 mM calibration solution should fit 0 on the y-axis, the signals for
the 15 mM calibration solution should fit 15, etc.

* With the graph selected, click-drag on an area of interest to create a zoom rectangle; the
rectangle can be repositioned in the window by dragging its border. If you click-hold
within the zoom rectangle a pop-up menu will appear. Select "Expand" and the data
will be zoomed from the rectangle to fill the graph window. The Undo command
restores the graph to its original dimensions.

* After zooming an area, the plotted data within the window can scrolled and moved
around by holding the Option or Alt key down while click-dragging with the mouse;
the display is updated after releasing the mouse button.

* To quickly check the values in the graph, activate the Graph window and then select
Graph ➔ Cursor Readback ➔ Start Cursor Reading. (Note: If a non-graph window such
as the Experiment/ROI Browser is active, a message will appear reminding you to
activate the Graph window first.) An information panel will appear at the top of the
graph; as the cursor is moved over the graph it changes to a cross-hair pointer and
information about its x-y location is dynamically updated in the panel. (Unfortunately,
Cursor Reading stops updating while the pointer is over a graph’s A or B cursors,
described below in Measuring Data, and therefore cannot be used to monitor a
cursor’s position while dragging it.)  Clicking on the graph prints the current pointer
position in the history area of the Command Window. To turn off Cursor Reading
select Graph ➔ Cursor Readback ➔ Stop Cursor Reading.

* You can smooth the data as follows. Duplicate the data folder by highlighting it in the
Data Browser and then selecting Edit ➔ Duplicate (or cmd-D / Ctrl-D from the
keyboard).  Add "_Smooth" to the name of the new folder in the Data Browser and
delete the "0" which was appended to it.  Drag the red arrow in the Data Browser list
until it points to the new "_Smooth" folder. Select Analysis ➔ Smooth... , select all of
the "R" waves (highlight R2 to Rn in the list), specify a desired smoothing function,
and then click "Do It".  To see the effects of smoothing in the graph use the
Experiment/ROI Browser to move to Next Run. The current cell's ratio wave will
change to show the smoothed data, and the label will change in the upper left corner of
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the graph, reading "_Smooth" after the filename. You can move through the cells and
click Next Run or Previous Run to see a cell's trace with or without smoothing.

* To copy the currently-displayed graph to the RatioImg Notebook click the "Graph to
NB" button. To view the notebook select Windows ➔ Other Windows ➔ RatioImg
Notebook.  Clicking the asterisk-labelled button next to "Graph to NB" will open a
dialog box prompting you for the number of cells to copy into the notebook, starting
with the currently-displayed cell. The "(n -1)" in the prompt is a reminder that, e.g., if
you are copying from cell 2 to cell 30, there are 29 cells to copy total.

* It is often helpful to highlight part of the graph's background to show the application of
an experimental solution, as seen in the sample Igor experiment in the RatioImg archive
file.  It is best to do this before you batch-copy graphs to the notebook.  Activate the
graph and select Graph ➔ Show Tools. Click on the second (i.e., lower) button that
appears in the graph; an array of drawing tools will appear below it. Holding down on
the Option key (for the Mac) or Alt key (for Windows), click and hold on the 2nd tool
from the bottom, which looks like a palm tree. A list will pop up; change the checked
item from User Front to User Back. Then use the rectangle tool to draw a rectangle as
wide as the time interval you want to highlight and about as tall as the y-axis of the
graph. With the rectangle still selected click on the palm tree tool and change the Line
Color and Fill Color to the lightest shade of gray available in the pop-up palette. You
can then drag the rectangle or use the arrow keys to nudge it around until it fits on the
graph as desired.  The shaded rectangle appears behind the plotted data and highlights
the time-interval of the experimental solution application. You can also use the text tool
to label the graph so that you can see at a glance what solution was applied and for how
long.  To ensure that the elements you have added to the graph maintain their exact
positions during resizing (which occurs when the graph is copied to the notebook),
double click on each element to open a dialog box. In the upper left corner there are
two popup menus. Choose “Axis bottom” from the X popup menu and “Axis left from
the Y popup menu”. Click “Do It”.  The boxes and text will now rescale correctly; you
can test this by resizing the Graph window.

* The graphs should appear two-across in the notebook. They can be printed 12 to a page
(i.e, in a 2 x 6 array on a standard US Letter page) by going to File ➔ Page Setup for
This Notebook... and setting the printing size to 60%.  (It may also be necessary to
enable the Larger Print Area (Fewer Downloadable Fonts) selection in the Options...
dialog box.) These settings work for an Apple LaserWriter 16/600; you might have to
tweak them when using a different printer.

4. Measuring Data

* Choose RatioImg ➔ View Measurements.  A window containing a table will appear
having columns labeled with various measures.  Arrange the windows on the screen so
that they are non-overlapping.



Page 11

* Click on the graph.  If the Info panel isn't showing at the bottom of the graph, choose
Show Info from the Graph menu (or cmd-I / Ctrl-I from the keyboard). Drag cursor A
(the round one) onto a wave and put it where you want to start measuring.  Drag cursor
B (the square one) onto the same wave and put it where you want to stop measuring.
To move a cursor in fine increments, deselect the other cursor by clicking its symbol in
the lower left of the graph window (when deselected it will change from black to
white), and then use the arrow keys to move the remaining selected cursor one point at
a time along the wave.

* Activate the Experiment/ROI Browser window, then click the "Measure" button.  Three
things will happen: 1) A red curve-fit line will appear on the graph, calculated from the
wave segment defined by the A and B cursors.  2) The Measurements window will
update, filling the next available row with measurements taken from the defined wave
segment.  3) The history area of the Command window will display the measured
values. Each click of "Measure" adds a new row of measurements to the table. Clicking
"Del Last" removes the last row of measurements and prints "Last set of measurements
deleted" in the history area of the command window.  Clicking the asterisk-labelled
button next to "Measure" will open a dialog box prompting you for the number of cells
to measure, starting with the currently-displayed cell.  Likewise, clicking the asterisk-
labelled button next to "Del Last" prompts for the number of measurements to delete
from the end of the Measurements table.

* You should apply measurements to relatively straight segments of a wave in order to
determine steady-state baseline values or linear rates of ion concentration change due to
the experimental manipulations. The measure of standard deviation is probably only
useful for steady-state conditions. It can also help quantify the variability in your cells'
steady-state signals if you compare this value to one obtained using a fluorescence
standard such as fluorescent beads. Pearson's r indicates how well the data fit the
calculated line between the A and B cursors; noise in the data will shift this value
towards zero. The yStart and yStop values show the measured values at the A and B
cursors, providing a quick (though not necessarily accurate) way to assess level changes
in intracellular ion concentrations at different times in the experiment.

* Move the A and B cursors to define a number of different areas on the wave and then
measure them. The curve-fit line will be redrawn for each newly-defined segment. The
Start and Stop values in the table show the time interval of each measurement, provided
that the x-scaling is set correctly. (As a reminder, before loading the data you can set
the number of ratio-pair samples per minute in the dialog box RatioImg ➔ Data
Loading...).

* Move to the next cell or previous cell using the buttons on the Experiment/ROI
Browser panel. Notice that the A and B cursors are positioned on the new trace using
the same x-coordinates.  You can define a single segment with the A and B cursors and
move through the traces for each cell, making measurements of the same time-segment.
As the measurements are made they are sequentially added to the measurements table.
To automate this, click the asterisk button next to "Measure" and enter the number of
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cells to measure. The dialog box remembers the last number you entered, which is
convenient for measuring different A-to-B segments in the same group of cells.

* You'll also notice that the line-fits accumulate in the graph when you move to different
cells and measure the same defined wave-segment. This can be very handy if you want
to compare the slopes and relative magnitudes of a response from a group of cells
which were subjected to the same experimental treatment. (NB: It is common to apply
experimental solutions to cells in a perfusion bath chamber, in which case all cells
respond more or less simultaneously.)  You can remove all fitted lines from the graph
by clicking the "Kill Fits" button in the Experiment/ROI Browser panel. You cannot
select individual line-fits for deletion in the Experiment/ROI Browser panel, but this
can be accomplished by other means in Igor.

* After measuring different cells over various time-segments you can sort the
Measurements table by going to RatioImg ➔ Sort Measurements. The table is sorted
first by the Name column (that is, experiment . wave&cell ID) and then by the Start
column.  This organizes the measurements if you didn't make them systematically
during your browsing/measuring session.  You can then copy and paste the data from
the Measurements table into a statistics program or spreadsheet for further analysis. The
"Del Last" button provides limited editing of the measurements table before you copy
and paste.  To delete measurements which are not in the last position, you can change
their name so that they sort to the end of the table (e.g., put a "Z" at the beginning), sort
the table, then click the "Del Last" button.  If you want to delete the entire contents of
the Measurements table click the "Clear All" button. You will be asked to confirm the
deletion of all data from the table.

* The correction procedures “Correct Ratios” and “F/Fo” or “∆F/F” (described in the
Appendix) also calculate and store an averaged wave of all the cells in a Run folder. To
view this wave first select the corrected data folder in the Data Browser (drag the red
arrow until it points to the data folder), and then select RatioImg ➔ Graph Avg. The
graph will appear in a separate window; you can change its y-axis scaling as described
previously. The averaged wave provides a smoothed summary of the population
response of the experiment (provided that all the cells responded simultaneously), and
can also be measured with the Experiment/ROI Browser. This is a very quick way to
get the average values of an entire experiment.

This concludes the guided tour. Choose "Save Experiment As" from the File menu and
save the experiment to disk. You can later reopen the experiment, load additional data
sets, make more measurements, etc.

RatioImg Assumptions

These are most of the programming assumptions in the RatioImg procedures.
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Data file names are of the form "981209.CSV", and their file format is "CSV".  CSV
stands for "Comma-Separated Variable" which is a type of text file that can be
read/written by most spreadsheets, including Excel.  RatioImg CSV data files begin with
two columns of background ROI data followed by 1 or more pairs of ROI data for each
measured cell.  The RatioImg procedures can subtract the first two columns of data from
the subsequent pairs of data, providing general correction for background fluorescence.
The first column-pair of data are not treated as data from a cell.  Even if background
subtraction is not a concern, you should create a background ROI to fill the first column-
pair in the data file when setting up your experiment. Doing so will insure that the
numbered labels on the graphs created by the RatioImg procedures match the ROI
numbers in your original data file.  This is important in order to match the data from an
ROI to an image of the corresponding cell; for example, you might want to measure the
response of cells identified via immunostaining or fitting certain morphological criteria,
etc.

"Run" data folders have names of the form "R981209". This is set by the
LoadRatioImgFile procedure. Without an "R" at the beginning of a folder name followed
by six digits the Experiment/ROI Browser will not load the folder's contents.

Calibration data must be entered in ascending order in the Set Calibration Periods panel;
i.e. period 0 should be the lowest calibration solution used, period 1 should be the next-
lowest calibration solution used, etc.  Note that the calibration solutions may be applied
in any order at the end of an experiment.  It is only necessary to enter the Solution values
in ascending order by Period; the corresponding Center Time values can occur in any
order relative to Period.

The RatioImg procedures also contain many widely-distributed programming
assumptions. For example, the original procedures set the number of calibration solution
periods to three. This was later expanded to allow up to 10 calibration periods, which
required careful editing of many of the procedure files. You should attempt this type of
modification only after you are comfortable with Igor programming. Changing one part
of the code will often have unwanted effects elsewhere due to numerous assumptions that
were made in the original procedures. You will need to look through the procedure files,
find all of the instances where such assumptions exist, and either change them to fit your
new set of assumptions or make them work in a more general way.

Wish List

The following features were regarded as either non-essential or too complex to
implement for the first release of RatioImg. They are listed in descending order of
importance.

1. Create a function in the Experiment/ROI Browser allowing the user to jump to a
specified cell instead of having to page through the run sequence using Next Cell or
Previous Cell.
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2. Enable the user to tag the data from problematic cells and not show them thereafter.
Cells having weak signals, dye bleaching, cell death, movement during recording,
etc. could be ignored during data analysis and measurement.  Currently the user
must either keep track of these cells while making measurements (and avoid
measuring them) or measure all of the cells and then delete the data from the
problematic cells afterward.

3. Create a calibration correction routine based on the formula of Grynkiewicz, Poenie,
and Tsien (1985).

4. Clean up the calibration routine for plotting ratio values which exceed the average
ratio value calculated from the highest calibration solution. Currently these points
are not well-handled by the calibration routine, resulting in drop-outs or
exaggerated points in the data plot which are distracting. Also, measurement of
plots containing NANs generates an error message, a minor nuisance.

5. Add a means of selecting a row or multiple rows of data in the Measurements table
and deleting it.

6. Create a routine to tag and sort data into groups for viewing such as high, medium,
and low-responding cells. This would be an elaboration of the ability to view a
subset of cells (i.e., viewing good cells/not viewing problematic cells) described
above.

7. Create a routine to simultaneously view a group of traces in the same graph, such as
"First 10 cells", "Next 10 Cells", etc., with the ability to specify the size of the
group. Ideally, this would also work within the sorted cell groups described above.

8. Set up a dialog box allowing the user to choose the display of different
measurement parameters shown in the Measurements table, similar to the public-
domain image analysis program NIH Image.

Customizing the Procedures

The RatioImg procedures illustrate what can be done with IGOR Pro and provide a
starting point for further refinement and development. Major changes will require the
services of an Igor programmer, either home-grown or a consultant. However, many
useful minor changes can be easily implemented after reading the comments in the
procedure files.

For someone interested in taking this package further, the following steps are
recommended:
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1. If you haven't done so already, do the Guided Tour of Igor. This is a booklet that
comes with Igor Pro.

2. Read this documentation file and do the RatioImg Guided Tour.

3. Read the Procedure Windows chapter in the IGOR Pro User's Guide.

4. Once you understand how the procedures operate read the procedure files; they are
heavily commented.

5. Refer to the Igor Programming and Advanced Programming chapters in the Igor
Programming and Reference manual. These chapters should help you understand
the design of the procedures and give you ideas about how they might be modified,
expanded, or customized.

6. Try writing some procedures of your own.

RatioImg Global Variables

There are two kinds of globals (variables and waves) used in these procedures. "Package"
globals are stored in the root:Packages:RatioImg data folder and apply to all data sets.
"Run" globals are stored in the data folder containing a particular data set and apply to
that data set only.

Package Globals

These variables and waves are stored in the root:Packages:RatioImg data folder and are
used by many of the procedures. They are created by the InitRatioImgGlobals routine.
Some of the variables are described as defaults. This means that when we load a new data
set, these variables are used to create the corresponding run variable in the data folder
containing the newly-loaded data.

gDebugMode Variable. If non-zero, debugging messages are printed in
the history at various points in the procedures. Each bit
turns on debugging printout as follows:

  Bit 0: CreateRatioImgCorrectedRatio

l Other bits are reserved for future use and should be set to
zero.

gSamplesPerMinute Variable. The default number of samples per minute in the
input data.
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gFirstDataLine Variable. The first line in an input data file that contains
numeric data. This will normally be 3.

gMakeTable Variable. = 1 if a table is to be made of the data after
loading it from a file. This will normally not be necessary.

gDoBkgSub Variable. = 1 if a background subtraction is to be done
when loading the data. By default this setting is 0 and
must be set to 1 before loading a file with valid
background data. If you always subtract background
values you can change the default to 0 so that you don't
have to change the setting each time you run the program.

gNumPeriods Variable. The default number of periods to be processed.
For example, if we are using 0, 30, and 100 millimolar
sodium calibration solutions, gNumPeriods will be 3.
Currently set to 10.

periodInfo Wave. periodInfo contains 6 columns and n rows, where n
is the number of calibration periods of interest.

The meaning of the columns is as follows:

Column 0 contains the starting time in minutes for that period.

Column 1 contains the ending time in minutes for the period.

periodInfo wave Table

period0

period1

period2

start time end time solution avg value slope intercept

etc. up to 10

period0 period1 period2Experiment

Calibration

period3
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Column 2 contains the calibration value of the solution in millimoles.

Column 3 contains the average value for the period.

Column 4 contains the slope of the line from the average value for the period to the
average value of the next period.

Column 5 contains the intercept of the line from the average value for the period to
the average value of the next period.

Columns 3, 4, and 5 are set by CreateRatioImgCorrectedRatio and are stored for
debugging purposes.

Run Globals

These variables and waves are stored in the data folder containing the data for a particular
run. They are created by the CreateNewRatioImgData-Folder routine. The initial values
come from the corresponding default globals in the root:Packages:RatioImg data folder.

gSamplesPerMinute Variable. The number of ratio-pairs sampled per minute.

gNumPeriods Variable. The number of periods to be processed. For
example, if we are using 0, 30, and 100 millimolar sodium
calibration solutions, gNumPeriods will be 3.

periodInfo Wave. See description of periodInfo above.

gNumDataPairs Variable. The number of A/B pairs loaded from the data file.

gRatiosCorrected Variable. This is initially set to 0 and then set to 1 when the
ratios are corrected.

gDoBkgSub Variable. Set to the value which was used when the waves
were loaded in the folder; see description of gDoBkgSub
above.
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Appendix

Working with Single-Column per ROI Datafiles

If your data is already calculated as ratio values or exists as single-wavelength values you
can load it as follows:

1. Save the data in CSV format. Strip out any extraneous columns, leaving only the
data values. (For example, Inovision data files use a timestamp and a unique
number reference in the first two columns. Delete these columns before importing
the data into RatioImg). You should also name the file as [six digits].CSV; e.g.
990202.CSV. RatioImg will not work with the file unless its name follows this
format.

2. Launch Igor. Follow the instructions for setting up an experiment, but stop before
loading the data file. At this point you may want to change the "Number of samples
per minute" value in the RatioImg ➔ Data Loading... dialog box. Background
subtraction can also be enabled at this time.

3. From the RatioImg menu select "Load Single-Column Data..." and select the file in
the Open File dialog. The data will be loaded and a folder in the Data Browser will
appear with the name "R" followed by the data file name.

4. Select the newly-created folder in the Data Browser. Select RatioImg ➔ Create
Graphs. The graph window will appear displaying the data from wave R2. The
Experiment/ROI Browser and Set Calibration Period control panels will also open
at this time.

5. The graph will have a single y-axis, scaled from 0.4 to 4. To rescale the axis, either
execute the autoscale command (cmd-A or Ctrl-A), use the RatioImg ➔ Axis
Ranges... dialog, or double-click on any axis label value to open the Set Axis Range
dialog and edit the settings. (The hard-wired default values are located in the
RatioImg Style function in the RatioImg Graphs procedure file if you want to
permanently change them.)

6. It is often useful to view fluorescence data plotted relative to baseline
measurements, i.e., as F/F0 or ∆F/F. This can be accomplished using either the
“F/F0” or “∆F/F” button on the Set Calibration Periods control panel. (The
proportional changes are calculated identically for both buttons; the baseline of F/F0

is set to 1 whereas the baseline of ∆F/F is set to 0.) First select the baseline period
for the calculation by setting the Center Time and Duration values for Period 0.
Clicking either of the “F/F” buttons will cause the procedure to check to see
whether the correction has already been made, in which case a message will be
displayed to this effect. Otherwise a dialog will appear asking whether you want to
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proceed. You should click "Yes" only if you are certain that the calibration period
settings for Period 0 are correct. Clicking "No" will abort the F/F0  or ∆F/F
calculation procedure and allow you to check the settings. If you click “Yes” and
the data were not background-subtracted by RatioImg during loading another dialog
will appear as a reminder, and you may elect to either perform the calculation
without background subtraction or cancel it.

The loading procedure imports the single-column data as the A waves, creates dummy B
waves for purposes of subtraction and “ratioing” (where R = B/1), then deletes the A and
B waves, leaving the bkgA, bkgB, and R waves in the data folder. The R waves can then
be browsed, calibrated, measured, etc. using the RatioImg procedures.  Note that the
same advice regarding background subtraction applies; namely, the first column in the
dataset should always contain values from background (i.e., non-cell) fluorescence. This
is true even if your data consists of precalculated ratios, although obviously you should
not perform background subtraction when working with data which has already been
ratioed.

Again, the reason for always having background data in the first column (or first column-
pair) is so that your original ROI numbers match the labels on the graphs; this allows you
to directly identify a cell with its data. You are never required to perform background
subtraction; this is completely optional.

Version 1.0, released 99/04/12.

Thanks to Bela Farago, who wrote the Cursor Readback procedures and generously donated them
to the Igor community.

Please send comments, bug-reports, questions, or suggestions to Mark N. Rand at
mnr@u.washington.edu.
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