Export issues, 'Invisible' integration, and bad timestamps for input

Hoping to get some help on a few issues – I am a beginner and only use Igor Pro (using version 6.37) for the Iolite add-in (LA ICP MS geochronology) and so am not familiar with coding. I am having two issues:

Issue #1:

When I go to export the data I get the error message “the functions DateStr2Date1904() was called with a bad input (“01/01/1904 (6) 08:29.52”), instead of the expected Igor date/time string form of “20/04/2007 (6) 12.53:45.20”. I figured out that this is caused by a single integration in the output data table that have an incorrect timestamp (i.e., 01/01/1904 (6) 08:29.52) and no data values associated with it.

The issue is that I cannot seem to remove this point; it is physically present in the output table and any graphs/waves but it is not in the trace window as an actual integration. In the data report section it is there, but ‘invisible’ – it has no error bar associated with it but is clearly there when you hover over the space next to integration number #132.

I have tried the following:

  • to Save and Kill all waves associated with this data point in ‘Browse Waves’
  • Removing it from the original raw data file – which doesn’t work as it is not a data raw point but an additional integration.

Issue #2:

To try and solve Issue #1 I attempted to re process the dataset from the start but I get the following error when I import my Agilent csv file: “It appears that this is the first time you’ve opened an Agilent file. You will need to specify your time stamp”. I selected all the possible timestamps available and even made a custom one that matched the raw file but it will not recognize any timestamp. My timestamp (which I have always used with no issue) is dd/mm/yyyy hh:mm:ss (e.g., 15/04/2021 10:04:31.00). I have tried using the Tweaks option for the delimited text file to change the format from mm/dd/yyyy to dd/mm/yyyy but this didn’t work.


Uninstalling and reinstalling will be my last resort!

Please help!



I would contact the manufacturer as this looks like a very specific problem with their Igor Pro software package.