Igor 7 keyboard shortcut changes

I recently upgraded from Igor 6 to 7 and love it. The shading option for error bars alone is worth the upgrade! However, I have not figured out how to keep using a few details of the interface.

1. The following keyboard shortcuts no longer seem to work in Igor 7 in Mac OS:

Cmd-Ctl-e: move active window to the back
Cmd-Ctl-Shift-e: move backmost window to the front

I found these more convenient than the Mac OS’s own standard shortcut, Cmd-`, because the Igor version kept the windows in a “circular” stack (front moves to back or back moves to front).

Are there new keyboard shortcuts for moving windows back and forth?

2. The up arrow used to reliably take the cursor from the command line to the history window. Now it usually does, but not always. Is this normal behavior? Is there another shortcut to go from the command line to the history pane?


1. We believe that we blocked the OS-driven window cycling (which we and I think most of our customers dislike) and replaced it with, I hope, the old behavior. So Cmd-` should be Move to Back and Cmd-Shift-` should be Move to Front. If it's not, please send a bug report to support@wavemetrics.com.

2. Up arrow in the command line should always highlight the first command that can be found in the history. It looks for the bullet character to find commands. Up arrow in the history should take you to the command above whatever line is currently highlighted in the history. If there are no commands, these situations should highlight the last line of the history, or the next line upward. Is it possible that you have a modified key (like Shift) accidentally held down when you press up arrow?

John Weeks
WaveMetrics, Inc.
Thank you for your reply, John.

1. I had not noticed that the keys that normally trigger the OS-driven window cycling, Cmd-` and the same thing plus Shift, have replaced the role of Ctrl-Cmd-e that I was looking for. Yes, they do exactly what I wanted, i.e. cycle through the windows in a ring, not in some non-commutative stacking manner. Thanks!

2. The strange behavior of nothing happening when i press the up arrow occurs regularly, without me accidentally pressing another key. I have not figured out how to make it happen, but it may occur specifically when I got to the command window from a procedure window, pressing Cmd-j. Today Igor on the same computer also showed other strange behavior like a popup menu selection not being the one that I had tried to select, which makes me worry about some serious instability possibly related to the OS (i just upgraded to Mac OS High Sierra). I may try a reinstall of the OS and go from there. Good to hear the intermittent arrow-key failure not a recognized bug.

I'm glad we have problem 1 nailed down!

Does the problem with up-arrow happen just since you started using High Sierra? Is it possible that you have some sort of Mission Control shortcut defined (possibly accidentally...) that is stealing the key press?

John Weeks
WaveMetrics, Inc.

I'm suddenly not able to use the up arrow in IGOR version 9.00 64-bit (and the up-arrow works in other programs on my Windows 10 Dell laptop computer).  The other arrows work in IGOR.  Any idea how to fix this?  I installed Adobe acrobat today but I don't know if that's when this started (and I have no idea why that would matter, but thought I should mention any recent changes like that).


My apologies to John Weeks for abandoning this thread. I accidentally solved my problem and never came back here to mention the solution.

Sara: when the up arrow does not work in Igor, which in my case occurs when I am in the command window, the problem is something about the previous command being half-executed or somewhere in limbo. Regardless of the details, what works for me is to press Return once or twice. This results in the history window showing the filled black circle again, and then the up arrow works (navigates into the history pane). Hope this works for you too.




Since you posted here, I presume you mean that up-arrow doesn't work to move the selection to a command in the history area above the command line. If it's some other use of the arrow key, let us know.

On my Windows 10 machine, the up-arrow key works as expected. I think on some keyboards there are toggle keys that can re-purpose some of the function keys to other uses. I wonder if you have accidentally pressed such a key?

If installing Adobe Acrobat caused such a problem, we would probably have heard about it by now.

Thanks for your quick replies!  It was occurring in the main procedure window, actually.  I rebooted the program and it is no longer happening... (and I hope it doesn't happen again)

Pietro was apparently working on his reply while I was working on mine...

By "filled black circle" do you mean the bullet character at the start of each command line?

Indeed, if a user function or a built-in command is running and taking a long time to finish, that would prevent the up-arrow key (or any key, we hope) from doing its job.

Also, if the Command/History window isn't the active window, keystrokes will go somewhere else. Could that be the problem?