<Urgent help request>IGOR getting stuck in processing data


I am in need of some urgent advice. I am running an IGOR-based software called Tofware which is used to analyze output from a specific time-of-flight mass spectrometer. I can load files to the program, mass calibrate etc. but for some reason, as soon as I try plotting the time series data, IGOR hangs up. [IMAGE FILE ATTACHED] I am totally stuck here and can't proceed with my analysis. Surprisingly, the same software had worked swimmingly well on a lab computer and also on a friend's computer which made me think that this may just need more RAM to work. However, at home, I am trying to test operate on data files that are just a few MB in size so there is no reason for the software to get stuck..My computer has i7, 12 GB RAM and 2 GB of dedicated Nvidia graphics to support RAM. I'm not sure what is making IGOR hang up in processing.  

Can someone please advise what may be the issue here? Since Tofware works perfectly normally on the other computers I have tried, could it be that I am not setting the IGOR environment correctly somehow? I'd be very thankful for any advice.. 



Error screen image

Have you contacted the developer of the package?

The error message suggests that your license file for the package is potentially corrupted. Does this make a difference?

The program appears to be XOP based. Do you have the proper configurations on your new computer?

What happens when you try to plot time series data from an even smaller file?

Yes, contact the maker. As I recall, they put quite a bit of effort into getting it to work on Igor 8, but maybe I've got that wrong. In any case, another thing to check is to make sure your version of Tofware is compatible with your version of Igor.

Thanks jjweimer and johnweeks for your comments! 

I also did the checks based on your comments, and eventually, with the help of Tofware support, this issue is resolved now.

Sorry, I should have mentioned that. 

So, the IGOR extension XOP file shortcuts (relevant to Tofware) were pointing to source XOP files located on a cloud folder instead of the local hard drive. This somehow caused the issue where some aspects of the program worked while some others did not. The program started functioning normally when all source XOP files got moved to a local folder. I believe Tofware support is looking into the underlying reasons for this observation. 


I don't know why an XOP wouldn't work that way, but it would probably affect performance greatly. Igor needs to load and call actual code from the XOP file- on Windows an XOP is a dll. So it's not surprising in a general way that it might not work well, or possibly at all.