Monte Carlo Error Analysis with Motofit

I have been trying to calculate the uncertainty in the parameters obtained from fitting a titration curve with a custom fit function. As suggested in previous posts, the motofit package can be used for this purpose.

However, I have not been able to obtain meaningful results with the Moto_montecarlo function in the the latest release of the motofit v4 package ( ). The matrix generated contains the same values for all the rows. These values are the same a the intial guess values. The command that I used is

Moto_Montecarlo ("myfitfunc", param_w, yy_w, xx_w, err_w, "holdstring", iter)

I also tried using a more recent version of the installer (, but Igor cannot find the definition for "sockitwavetostring."

I have two questions:

  • Has anyone tried using the Monte Carlo analysis in motofit with a user generated generated function?

  • Is there another version of motofit that I can use to run the Monte Carlo analysis? Ideally, I would like to use a version that runs multiple threads to speed up the process

  • Thanks
Isaac, I have tried doing this (I wrote the package).

Could you post a packed experiment file that demonstrates what you are trying to do?
Can you download and install the latest version and let me know if you still have problems?

I have just downloaded this and have checked that the code compiles. I also used this version to do a Monte Carlo analysis.

I remember fixing some issues along this line, when I was created code that could fit in parallel.

I'll pack an experiment with a simple example of what I am trying to do. In the mean time, I tried installing the latest version of motofit and I got three errors after executing the motofitInstaller.exe and restarting Igor. It seems I am missing a few XOP libraries.

First, I get a popup window saying "XOP dynamic link failed." Then, I get a compilation error for  sockitwavetostring . I commented the lines with the previous command. Finally, I got a compilation error for "easyhttp" which I also commented.

The previous errors disappear after running platypusInstaller.exe but I get two additional compilation errors.

1) A couple of commas were missing in the following line of Pla.reductionPOD.ipf
 print "(Polarized Reduction) These are the datasets in angle "ii": Ffname = ", Ffname

2) a missing wave reference in Pla_Xrayreduction.ipf
wfprintf saveID, "%g \t %g \t %g \t %g \n", qq, rr, dr, dq

Thanks for the help

Shucks, looks like I'm going to be bug hunting.
When you get the message "xop dynamic link failed" does Igor give anymore information? I want to know which xop is failing to load.

It's probably better to email me directly.
I've just fixed the SOCKIT xop, but not easyHttp. You should be able to install Motofit from the release page, and it should work. Bloomin' Visual Studio. I never have these problems on OS X.

Just Motofit, you don't need to install platypusInstaller.exe