Zoom level / text size in Windows

In Windows 10, my Igor 9 looks too small.

I can right-click and change Zoom level on the command line and history, but not in the menus.

I played with Misc -> Settings -> Miscellaneous -> Disable High DPI Scaling, but that didn't do the trick.

Am I missing something? I'm struggling to read the menus, in order to figure this out.

What is the value of your Windows size setting (Settings => System => Display => Scale and Layout)? Igor should scale all elements with this setting. If you are at 100%, this may look pretty small on large displays. Try to set a higher value and see if this is better.

It is 150%.

I previously used this setting to modify Igor, but now I can't see any changes.

On my LAPTOP screen I see Igor with large text, but on my EXTERNAL docked monitor I don't.

Please execute:

DisplayHelpTopic "Windows High-DPI Recommendations"

This gives our recommendations for a setup similar to what you describe.

I believe the Scale and Layout setting is set for each monitor separately. So when you have your external monitor attached you might want to check this setting again after clicking on the external one (I guess this will be display 2 then). The setting might be 100% here.

In reply to by aclight

aclight wrote:

Please execute:

DisplayHelpTopic "Windows High-DPI Recommendations"

This gives our recommendations for a setup similar to what you describe.


@aclight, this brought up the following instructions for me:

 

Quote:

  1. Connect the external standard-resolution monitor.
  2. Open the Display settings page. You can do this by right-clicking the Start menu, choosing Settings, clicking System, and selecting Display in the lefthand pane.
  3. In the Multiple Displays setting, near the bottom of the pane, select Extend These Displays.
  4. Click the Identify link below the diagram of your displays at the top of the pane to confirm which display is which. For these instructions, we assume that display #1 is the high-resolution built-in display and display #2 is a standard-resolution external monitor.
  5. Click the box representing the built-in high-resolution display (display #1 for this example).
  6. Set Resolution to the recommended value, such as 3840 x 2160.
  7. Set Scale and Layout to the recommended value, which may be 200%, 225%, or 250% depending on your hardware.
  8. Check the Make This My Main Display checkbox near the bottom of the pane.
  9. Close the settings control panel.
  10. Reboot your machine twice. To get the best results, you must reboot your machine 2 times after any changes to the display settings.
  11. Go to Misc -> Miscellaneous Settings -> Miscellaneous (section at left), and enable the option 'Disable High-DPI Scaling'. Then restart Igor.
  12. After your machine restarts twice, start Igor. Except for occasional minor glitches, it should work properly.

Step #11 inserted in bold was not part of my Igor 8.04 instructions. I tested this and found that it was necessary to solve my menu scaling issue. I had tested this before and it was not sufficient by itself. 

Thanks!

Well, that 150% scaling is problematic because the Qt framework (wrongly) assumes integer scaling. If you can get along with 100% or 200% that may give better results.

In my experience, this was more common on laptop monitors, and is less common recently.